SCE 2010 Installation error: This instance cannot be used for the Essentials database


When will you be faced with this problem?

  • New installation of SCE 2010
  • WSUS is already installed using an existing SQL server standard for its database

Problem description

When installing System Center Essentials 2010 for a client I faced the following error: “This instance cannot be used for the essentials database because it does not contain the windows server update services database”.

As you all know, WSUS needs to be installed on the SCE server. I knew the instance hosted the WSUS database. The problem is, that the SCE installer looks at the following reg key to locate the database server that is used by WSUS:

  • HKEY_LOCAL_MACHINESOFTWAREMicrosoftUpdate ServicesServerSetupSqlServerName

When installing WSUS, it will enter the FQDN of the SQL server in this registry key. The SCE installer can only cope with the NETBIOS name, which results in the error above.

The solution

How to solve this issue? Replace the FQDN by the NETBIOS name in this registry key:

  • HKEY_LOCAL_MACHINESOFTWAREMicrosoftUpdate ServicesServerSetupSqlServerName

And now bye bye installation error!

Ow yes, do not forget to not select “use microsoft update or installation” further on in the wizard or the install will fail. Long live bug-free installers J.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s